Struggling with eFNS

For the past three weeks I have been struggling with the eFNS site - most of the time it won't load, and the few occasions that it does load it tells me my credentials are wrong but whenever I try to reset the password I dont get any email to reset. Very confusing! Any advice, as I am wasting precious time when I need to get my paperwork in. Thank you!
To let you know, this has now been sorted. I called Nyayo House on 0110923424 and was told to go to the Foreign National Service area (back of Nyayo House) directly to Counter 8. I just walked in, did not need an appointment, though I needed to speak to the policewoman at the door to be allowed to go directly to Counter 8 as everyone waiting is waiting for fingerprinting and other such services. At counter 8, my account was reset and I was given a new password. I was told:

1) eFNS is best logged in at night or early in the morning as during the day it is very busy so access is a challenge.

2) The system is not yet set up to send emails so even if you request to reset your pwd online and it says a message has been sent to you, that does not happen.

3) Despite what the website says, eCitizen and eFNS are not liked so you cannot login via your eCitizen account, you have to create an eFNS account and log directly in to get passport services.

Hope this is helpful for others who get stuck!


I tried many times to reset password but efns system didn't send me reset link to my mail account.

Please resent it to me via ***


Moderated by Bhavna last year
Reason : Contact details should not be posted on the forum. Thank you
We invite you to read the forum code of conduct


Not Yest satisfied


Please just visit the counter as advised above. If you are not currently in the country you can send an agent or a Lawyer.

I created an eFNS account at ( and I can't log in. I get the error message that says "Provide valid login credentials."  When I try to reset the password, I get another error message.

When I emailed, they replied, "Kindly go through  The site they gave me does not have the https:// which makes me wonder if the site I used was real or not.

I get the same error messages at I cannot log in and I cannot change the password. I also tried to create a new eFNS account at this site (in case the other site I used was not the real site) and it says an account already exists with these credentials.

So, now I don't know if the site with the https:// is a phishing version of the real eFNS site (and someone used my credentials to create a real eFNS account, changed the email and password so I cannot access it) or if it is the same site and I just need a reset.

I emailed eFNS two weeks ago and did not receive  a reply. Is there any way to contact them from the USA?