EFNS Kenya portal

Hi guys,

Does anyone know what's going on with the eFNS Kenya portal? it's been giving me this message:

'Access token error: Sorry! Your account is not currently active Click here to go back'

for some time now so I can't access my application status and no response to my e-mail, I'm afraid I go to town and be directed right back to the website, any advice will be appreciated, thanks in advance!


Dear Razan1,
yes the EFNS site has been down for quite some time now. I went to Nyayo house to get informations and was told to go on the site and complain there  :lol:

Hi there,
Sadly the government moved services online prematurely and now the clients are suffering from it. From a few experiences I have had with the site, try see if it will work at night. (sometimes it can be offline all day and work at nigh.
If it is for services accessible through Ecitizen try using that route as it is more reliable

Hi JL Alexander,

Thanks for your reply, that's just hilarious! Was afraid of exactly that though, town is such a mission, you saved me the trip, will keep checking every now and again and see how much longer this goes on for.

Hi Mwaniki,

Thanks for your reply, you're right I used to access the eFNS through the ecitizen account, but now that's the access I can't get through, ecitizen works fine but the immigration stuff applied through eFNS isn't visible through ecitizen. I'll try and login at night and see though thanks.

Razan1, I have been receiving the same error since Sat, May 8, 2021. Seems like a system-wide error for those trying to log into eFNS via eCitizen. I have not been able to reach anyone on the phone for help. I have sent an email to fnshelp@futuristic.co.ke, but have not received a response. Hopefully, they will resolve this issue soon.

Hi mattro87,

Thanks for your reply, yes I also tried the phones but no response and sitting tight for an e-mail response as well, we really hope it gets resolved!


I been also trying to login for over a week. Last year, the same issue occurred and took a while to correct it.

Don't worry you account is there. Try to create another account and it will say it exists.


I called the futuristic support center and Apparently the IT guys repairing it are "working from home"

Hi Dave,
Thanks for your reply, I hope so really don't want to restart my process again, will just have to wait and see, thanks again!

Thanks for your update, at least we know their IT are working!

This issue has been there since last 2 weeks and still persisting. Unfortunately, we cannot login to eFNS without it being fixed.

Hi Gouri,

Thanks for your reply, yes true, we'll just keep checking in on it every now and again because they insist that we use it for everything now!

Hi.my account was restored today.kindly anyone facing this problem go nyayo house 5th floor.at the entrance there is an officer attending to ecitizen queries. they will change your password and you will now be logging in through efns direct unlike before when you had to use ecitizen account to gain access.

Hi Denajay, oh really! thank you very much, will do that!

Hey did you ever get help?

Hey guys

has anyone had any luck with accessing  the eFNS Portal
Ive been in the process of Permanent Residency Application for 2 years.  Ive been told via message from Chief Immigration oifficer in Nairobi that my application was sorted 'a while' back and i was to check on the eFNS Portal for updated status.  But like youve previously said the portal is not 'opening' or 'down' 

Any advice

Hello. It could be a technical error on the website. Hopefully it will be up and running very soon.

Hi, I tried to do as Denajay suggested but unfortunately didn't get far and waited too long and had to leave in the end, but try as they suggested if you're on the same boat!

Hi Kerry, try as Denajay suggested although I didn't have any luck and was sent from the 5th floor to counter 8 where there was a queue and a few people with the same issue, you might have better luck!I will also try again, there's no other solution at the moment it's painful!

Lets hope so yeah, thanks!

Currently no hope visible, what to do.

Even i tried forgot password, but no link comes for reset at the email.

Hi, any luck here?

Hi Suvatia, it worked as suggested after my second trip, they have to reset it for you themselves it doesn't work if you try, go there and good luck!

Yes finally!

Dear All,

My issue got resolved by Immigration Team. You need to visit Nyayo House at Ground Floor Counter No. 6 and request the Officer on Duty to assist in dlinking eCitizen and register directly on EFNS. This took less than 2 minutes and could login successfully. Please remember to carry your ID.

Hope this will help.



EFNS only works if you do not use ecitizen